Raise minimum required version of Python from 2.6 to 3.0

Merged Alan Coopersmith requested to merge alanc/libxcb:python into master

I have an older machine which has both Python 2.7.14 & 3.5.3 installed.

Trying to build libxcb with the current setting requiring a minimum of Python 2.6 made configure choose Python 2.7.14, which failed with:

  File "./c_client.py", line 2270
    key = (*self.name[:-1], field.enum)
SyntaxError: invalid syntax

due to the changes @DemiMarie made in commit 33f3dbe3 ("Fix handling of documented enum parameters").

Raising the minimum to 3.0 made it instead pick 3.5.3 which worked fine. I've not tested with 3.0 or anything below 3.5.3, but have chosen 3.0 based on the version shown in PEP 3132 – Extended Iterable Unpacking.

Merge request reports