Document dependency for libgstreamer-plugins-bad1.0-dev

Sebastian Dröge requested to merge charlie-ht:master into master

Created by: charlie-ht

I saw this after doing a fresh checkout on Ubuntu 17.10,

error: failed to run custom build command for `gstreamer-player-sys v0.5.0 (https://github.com/sdroege/gstreamer-sys#d68a12a4)`
process didn't exit successfully: `/home/charlie/git/gstreamer-rs/target/debug/build/gstreamer-player-sys-8838fb523b245540/build-script-build` (exit code: 1)
--- stderr
`"pkg-config" "--libs" "--cflags" "gstreamer-player-1.0 >= 1.12"` did not exit successfully: exit code: 1
--- stderr
Package gstreamer-player-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gstreamer-player-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gstreamer-player-1.0' found


warning: build failed, waiting for other jobs to finish...
error: build failed

Add this dependency fixed the issue here. I assume the same will be true on Debian, but I haven't tested.

Merge request reports