Commit fb212f2c authored by Jon Turney's avatar Jon Turney

meson: Make VBE and VGAHW modules optional

Don't build them on platforms where they aren't meaningful.

Note that autoconf defines WITH_VGAHW when building the VGAHW module, but
that doesn't seem to be used anywhere, so we just drop that.
Signed-off-by: Jon Turney's avatarJon Turney <jon.turney@dronecode.org.uk>
Reviewed-by: Eric Anholt's avatarEric Anholt <eric@anholt.net>
parent 6d2b7d33
......@@ -260,6 +260,28 @@ if libdrm_dep.found()
build_modesetting = libdrm_dep.version().version_compare('>= 2.4.46')
endif
build_vbe = false
if get_option('vbe') == 'auto'
if (host_machine.system() != 'darwin' and
host_machine.system() != 'windows' and
host_machine.system() != 'cygwin')
build_vbe = true
endif
else
build_vbe = get_option('vbe') == 'yes'
endif
build_vgahw = false
if get_option('vgahw') == 'auto'
if (host_machine.system() != 'darwin' and
host_machine.system() != 'windows' and
host_machine.system() != 'cygwin')
build_vgahw = true
endif
else
build_vgahw = get_option('vgahw') == 'yes'
endif
# XXX: Allow configuration of these.
build_apm = false
build_acpi = false
......@@ -267,8 +289,6 @@ build_dpms = true
build_mitshm = true
build_res = true
build_screensaver = true
build_vbe = true
build_vgahw = true
build_xace = true
build_xsecurity = true
build_xf86bigfont = true
......
......@@ -49,6 +49,10 @@ option('hal', type: 'combo', choices: ['yes', 'no', 'auto'], value: 'auto',
description: 'Enable HAL integration')
option('systemd_logind', type: 'combo', choices: ['yes', 'no', 'auto'], value: 'auto',
description: 'Enable systemd-logind integration')
option('vbe', type: 'combo', choices: ['yes', 'no', 'auto'], value: 'auto',
description: 'Xorg VBE module')
option('vgahw', type: 'combo', choices: ['yes', 'no', 'auto'], value: 'auto',
description: 'Xorg VGA access module')
option('dri1', type: 'combo', choices: ['yes', 'no', 'auto'], value: 'auto', description: 'Build DRI1 extension (default: auto)')
option('dri2', type: 'combo', choices: ['yes', 'no', 'auto'], value: 'auto', description: 'Build DRI2 extension (default: auto)')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment