Commit 8751e341 authored by Alan Coopersmith's avatar Alan Coopersmith

xft.pc.in: Requires.private entries should not be duplicated in Requires

Users of libXft don't need to link with fontconfig, freetype and
Xrender directly if they don't use them.

This may cause issues for users of pkg-config versions older than 0.22.
Please upgrade to the 2007 version of pkg-config before trying to build
the 2010 version of libXft.
Signed-off-by: Alan Coopersmith's avatarAlan Coopersmith <alan.coopersmith@oracle.com>
Reviewed-by: Gaetan Nadon's avatarGaetan Nadon <memsize@videotron.ca>
parent ca575f9c
......@@ -6,7 +6,7 @@ includedir=@includedir@
Name: Xft
Description: X FreeType library
Version: @VERSION@
Requires: xproto, xrender, fontconfig, freetype2
Requires: xproto
Requires.private: xrender, fontconfig, freetype2
Cflags: -I${includedir}
Libs: -L${libdir} -lXft
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment