Commit 906259ec authored by Alan Coopersmith's avatar Alan Coopersmith

Set libtool version-number automatically from package version

Since we've forgotten to manually update in most libXft releases so far,
might as well just automate it.

Reported by: Paulo Ricardo Zanoni <pzanoni@mandriva.com>
Signed-off-by: default avatarAlan Coopersmith <alan.coopersmith@sun.com>
parent fc248fb4
......@@ -57,6 +57,9 @@ AC_DEFINE_UNQUOTED([XFT_REVISION],
[`echo $PACKAGE_VERSION | cut -d . -f 3 | cut -d - -f 1`],
[Micro revision of Xft])
XFT_LT_VERSION=`echo $PACKAGE_VERSION | tr '.' ':'`
AC_SUBST([XFT_LT_VERSION])
#
# Check for Xrender
#
......
......@@ -24,7 +24,7 @@ libXft_la_SOURCES = xftint.h \
libXft_la_LIBADD = @FONTCONFIG_LIBS@ @FREETYPE_LIBS@ @XRENDER_LIBS@
# -version-number requires libtool >= 1.5
libXft_la_LDFLAGS = -version-number 2:1:13 -no-undefined
libXft_la_LDFLAGS = -version-number $(XFT_LT_VERSION) -no-undefined
libXftincludedir = $(includedir)/X11/Xft
libXftinclude_HEADERS = \
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment