Commit a088af61 authored by Christophe Fergeau's avatar Christophe Fergeau
Browse files

2004-08-30 Christophe Fergeau <teuf@gnome.org>

	* Makefile.am:
	* configure.in: use m4 macros provided by pkg-config instead of using
	  our own
parent da9ac1f5
2004-08-30 Christophe Fergeau <teuf@gnome.org>
* Makefile.am:
* configure.in: use m4 macros provided by pkg-config instead of using
our own
2004-08-30 Christophe Fergeau <teuf@gnome.org>
* NEWS:
......
......@@ -25,8 +25,8 @@ EXTRA_DIST = \
CLEANFILES = intltool-extract intltool-merge intltool-update freedesktop.org.xml
CFLAGS = @CFLAGS@ `@PKG_CONFIG@ --cflags libxml-2.0 glib-2.0`
LDFLAGS = @LDFLAGS@ `@PKG_CONFIG@ --libs libxml-2.0 glib-2.0`
CFLAGS = $(ALL_CFLAGS)
LDFLAGS = $(ALL_LIBS)
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = shared-mime-info.pc
......
dnl Process this file with autoconf to produce a configure script.
AC_INIT(freedesktop.org.xml.in)
AM_INIT_AUTOMAKE(shared-mime-info, 0.14)
AC_PROG_INTLTOOL
AM_INIT_AUTOMAKE(shared-mime-info, 0.15)
AM_CONFIG_HEADER(config.h)
dnl Checks for programs.
AC_PROG_CC
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
dnl i18n
AC_PROG_INTLTOOL
GETTEXT_PACKAGE=shared-mime-info
AC_SUBST(GETTEXT_PACKAGE)
ALL_LINGUAS="az cs cy de el fi fr hu ko nl nn no sv sr"
AM_GLIB_GNU_GETTEXT
dnl Check pkg-config is installed
if test -z "$PKG_CONFIG"; then
PKG_CONFIG=pkg-config
fi
AC_SUBST(PKG_CONFIG)
AC_MSG_CHECKING(that pkg-config runs)
if "$PKG_CONFIG" --version > /dev/null 2>&1 ; then
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
AC_MSG_ERROR([*** $PKG_CONFIG missing ***
\'$PKG_CONFIG --version\' failed to run - make sure it is inside one of the
directories in your PATH environment variable!
pkg-config is available from this web page:
http://www.freedesktop.org/software/pkgconfig
])
fi
AC_DEFUN(REQUIRE, [
AC_MSG_CHECKING(that $1 (version >= $2) is installed)
if "$PKG_CONFIG" --atleast-version=$2 $1 ; then
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
if "$PKG_CONFIG" --exists $1 ; then
AC_MSG_ERROR(Current version is only `"$PKG_CONFIG" "$1" --modversion`)
else
AC_MSG_ERROR(Package is not installed)
fi
fi
])
dnl Check for libxml and glib
REQUIRE(libxml-2.0, 2.4.0)
REQUIRE(glib-2.0, 2.0.0)
dnl Checks for programs.
AC_PROG_CC
PKG_CHECK_MODULES(ALL, \
libxml-2.0 >= 2.4 \
glib-2.0 >= 2.0.0)
AC_SUBST (ALL_CFLAGS)
AC_SUBST (ALL_LIBS)
dnl Use -Wall, etc if possible
[
......@@ -71,9 +42,6 @@ AC_ARG_ENABLE(update-mimedb,
enable_update_mimedb=yes)
AM_CONDITIONAL(ENABLE_UPDATE_MIMEDB, test x$enable_update_mimedb = xyes)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
mimedir=['${datadir}/mime']
AC_SUBST(mimedir)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment