Commit 338106b2 authored by Xavier Claessens's avatar Xavier Claessens
Browse files

overlay: Fix qt support detection

On Ubuntu moc-qt5 command is called moc. This requires Meson 0.54.0 for
the new has_tools() method.
parent caca46e0
Pipeline #126325 failed with stages
in 7 minutes and 7 seconds
project('gst-plugins-base', 'c',
version : '1.17.0.1',
meson_version : '>= 0.48',
meson_version : '>= 0.54.0',
default_options : [ 'warning_level=1',
'buildtype=debugoptimized' ])
......
......@@ -12,9 +12,7 @@ if x11_dep.found()
qt5widgets_dep = dependency('qt5', modules : ['Gui', 'Widgets'],
required: get_option('examples'))
# FIXME Add a way to get that information out of the qt5 module
moc = find_program('moc-qt5', required : get_option('examples'))
if qt5widgets_dep.found() and moc.found()
if qt5widgets_dep.found() and qt5_mod.has_tools(required: get_option('examples'))
executable('qt-videooverlay', 'qt-videooverlay.cpp',
cpp_args : gst_plugins_base_args,
include_directories: [configinc, libsinc],
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment