ci: Install Wayland 1.21.0

Wayland >= 1.21.0 is required to compile libinput's high-resolution
scroll code paths.

Install it, as Debian has 1.18 only.

Signed-off-by: José Expósito <jose.exposito89@gmail.com>
9 jobs for wip/hi-res-scrolling in 16 minutes and 20 seconds (queued for 1 second)