Rename HAS_GESTURES to HAVE_GESTURES

HAVE_FOO is generally used everywhere (see HAVE_CONFIG_H) so let's keep
this consistent.

Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
2 jobs for inputproto-req in 5 minutes and 42 seconds (queued for 1 second)
Status Name Job ID Coverage
  Containers
passed fedora@container_build #13717821

00:04:37

 
  Build
passed fedora:33@default-build #13717822

00:01:05