configure.ac 5.18 KB
Newer Older
1
AC_PREREQ([2.64])
2

3
m4_define([wayland_major_version], [1])
4
m4_define([wayland_minor_version], [6])
5
m4_define([wayland_micro_version], [91])
6 7 8
m4_define([wayland_version],
          [wayland_major_version.wayland_minor_version.wayland_micro_version])

9
AC_INIT([wayland],
10
        [wayland_version],
11
        [https://bugs.freedesktop.org/enter_bug.cgi?product=Wayland&component=wayland&version=wayland_version],
12 13 14
        [wayland],
        [http://wayland.freedesktop.org/])

15 16 17 18 19
AC_SUBST([WAYLAND_VERSION_MAJOR], [wayland_major_version])
AC_SUBST([WAYLAND_VERSION_MINOR], [wayland_minor_version])
AC_SUBST([WAYLAND_VERSION_MICRO], [wayland_micro_version])
AC_SUBST([WAYLAND_VERSION], [wayland_version])

20
AC_CONFIG_HEADERS([config.h])
21 22
AC_CONFIG_MACRO_DIR([m4])

23
AM_INIT_AUTOMAKE([1.11 foreign no-dist-gzip dist-xz subdir-objects])
24

Kristian H. Kristensen's avatar
Kristian H. Kristensen committed
25
AM_SILENT_RULES([yes])
26

27 28
# Check for programs
AC_PROG_CC
Mariusz Ceier's avatar
Mariusz Ceier committed
29 30 31 32 33 34 35 36 37 38 39 40
AC_PROG_CXX

# check if we have C++ compiler. This is hacky workaround,
# for a reason why it is this way see
# http://lists.gnu.org/archive/html/bug-autoconf/2010-05/msg00001.html
have_cpp_compiler=yes

if ! which "$CXX" &>/dev/null; then
	have_cpp_compiler=no
fi

AM_CONDITIONAL(ENABLE_CPP_TEST, test "x$have_cpp_compiler" = "xyes")
41 42 43 44 45

# Initialize libtool
LT_PREREQ([2.2])
LT_INIT

46 47 48
PKG_PROG_PKG_CONFIG()
PKG_CHECK_MODULES(FFI, [libffi])

49
if test "x$GCC" = "xyes"; then
50
	GCC_CFLAGS="-Wall -Wextra -Wno-unused-parameter -g -Wstrict-prototypes -Wmissing-prototypes -fvisibility=hidden"
51 52 53
fi
AC_SUBST(GCC_CFLAGS)

54
AC_CHECK_FUNCS([accept4 mkostemp posix_fallocate])
55

56
AC_CHECK_DECL(SFD_CLOEXEC,[],
57
	      [AC_MSG_ERROR("SFD_CLOEXEC is needed to compile wayland")],
58 59
	      [[#include <sys/signalfd.h>]])
AC_CHECK_DECL(TFD_CLOEXEC,[],
60
	      [AC_MSG_ERROR("TFD_CLOEXEC is needed to compile wayland")],
61 62
	      [[#include <sys/timerfd.h>]])
AC_CHECK_DECL(CLOCK_MONOTONIC,[],
63
	      [AC_MSG_ERROR("CLOCK_MONOTONIC is needed to compile wayland")],
64 65 66
	      [[#include <time.h>]])
AC_CHECK_HEADERS([execinfo.h])

67 68
AC_ARG_ENABLE([scanner],
              [AC_HELP_STRING([--disable-scanner],
69
                              [Disable compilation of wayland-scanner])],
70 71 72
              [],
              [enable_scanner=yes])

73 74 75 76 77 78
AC_ARG_ENABLE([documentation],
	      [AC_HELP_STRING([--disable-documentation],
		              [Disable building the documentation])],
	      [],
	      [enable_documentation=yes])

79 80
AM_CONDITIONAL(ENABLE_SCANNER, test "x$enable_scanner" = xyes)

81 82 83 84 85
AC_ARG_WITH(icondir, [  --with-icondir=<dir>    Look for cursor icons here],
		     [  ICONDIR=$withval],
		     [  ICONDIR=${datadir}/icons])
AC_SUBST([ICONDIR])

86 87 88 89 90
EXPAT_LIB=""
AC_ARG_WITH(expat, [  --with-expat=<dir>      Use expat from here],
		   [ expat=$withval
		     CPPFLAGS="$CPPFLAGS -I$withval/include"
		     LDFLAGS="$LDFLAGS -L$withval/lib" ] )
91 92 93 94 95 96 97
if test "x$enable_scanner" = "xyes"; then
	AC_CHECK_HEADERS(expat.h, [AC_DEFINE(HAVE_EXPAT_H)],
			 [AC_MSG_ERROR([Can't find expat.h. Please install expat.])])
	AC_CHECK_LIB(expat, XML_ParserCreate, [EXPAT_LIBS="-lexpat"],
		     [AC_MSG_ERROR([Can't find expat library. Please install expat.])])
	AC_SUBST(EXPAT_LIBS)
fi
98

99
AC_PATH_PROG(XSLTPROC, xsltproc)
100
AM_CONDITIONAL([HAVE_XSLTPROC], [test "x$XSLTPROC" != "x"])
101

102 103 104 105 106 107 108 109 110 111 112 113 114 115
AC_MSG_CHECKING([for docbook manpages stylesheet])
MANPAGES_STYLESHEET=http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
AC_PATH_PROGS_FEATURE_CHECK([XSLTPROC_TMP], [xsltproc],
			    AS_IF([`"$ac_path_XSLTPROC_TMP" --nonet "$MANPAGES_STYLESHEET" > /dev/null 2>&1`],
				  [HAVE_MANPAGES_STYLESHEET=yes]))
if test "x$HAVE_MANPAGES_STYLESHEET" = "xyes"; then
	AM_CONDITIONAL([HAVE_MANPAGES_STYLESHEET], true)
	AC_SUBST(MANPAGES_STYLESHEET)
	AC_MSG_RESULT([yes])
else
	AM_CONDITIONAL([HAVE_MANPAGES_STYLESHEET], false)
	AC_MSG_RESULT([no])
fi

116
AM_CONDITIONAL(BUILD_DOCS, [test x$enable_documentation = xyes])
117
if test "x$enable_documentation" = "xyes"; then
118 119 120 121 122 123
	AC_PATH_PROG(DOXYGEN, doxygen)

	if test "x$DOXYGEN" = "x"; then
		AC_MSG_ERROR([Documentation build requested but doxygen not found. Install doxygen or disable the documentation using --disable-documentation])
	fi

124 125 126 127 128 129 130 131
	AC_MSG_CHECKING([for compatible doxygen version])
	doxygen_version=`$DOXYGEN --version`
	AS_VERSION_COMPARE([$doxygen_version], [1.6.0],
	                   [AC_MSG_RESULT([no])
	                    AC_MSG_ERROR([Doxygen $doxygen_version too old. Doxygen 1.6+ required for documentation build. Install required doxygen version or disable the documentation using --disable-documentation])],
	                   [AC_MSG_RESULT([yes])],
	                   [AC_MSG_RESULT([yes])])

132
	AC_PATH_PROG(XMLTO, xmlto)
133

134 135
	if test "x$XMLTO" = "x"; then
		AC_MSG_ERROR([Documentation build requested but xmlto not found. Install xmlto or disable the documentation using --disable-documentation])
136 137
	fi

138 139 140 141
	AC_CONFIG_FILES([
	doc/doxygen/wayland.doxygen
	])

142
fi
143
AM_CONDITIONAL([HAVE_XMLTO], [test "x$XMLTO" != "x"])
144

145
AC_CONFIG_FILES([Makefile
146
		 cursor/wayland-cursor.pc
147
		 cursor/wayland-cursor-uninstalled.pc
148
		 doc/Makefile
149
		 doc/publican/Makefile
150
		 doc/doxygen/Makefile
151
		 doc/man/Makefile
152 153
		 src/wayland-server-uninstalled.pc
		 src/wayland-client-uninstalled.pc
Daiki Ueno's avatar
Daiki Ueno committed
154
		 src/wayland-scanner-uninstalled.pc
155
		 src/wayland-server.pc
156
		 src/wayland-client.pc
Daiki Ueno's avatar
Daiki Ueno committed
157
		 src/wayland-scanner.pc
158
		 src/wayland-version.h])
159
AC_OUTPUT