wpe: Remove code targeting WebKit < 2.24

We already depend on wk >= 2.24

Part-of: <gstreamer/gst-plugins-bad!2167>
30 jobs for !2167 with backport-mr-2165-into-1.18-wpe-threadedview in 33 minutes and 20 seconds (queued for 5 seconds)
merge request