Commit 6c26b44f authored by Tim-Philipp Müller's avatar Tim-Philipp Müller 🐠
Browse files

examples: always build against gtk3

Drop gtk2 option.

https://bugzilla.gnome.org/show_bug.cgi?id=796243
parent 76f3dcb8
...@@ -278,24 +278,11 @@ AC_SUBST(XML_CFLAGS) ...@@ -278,24 +278,11 @@ AC_SUBST(XML_CFLAGS)
dnl GTK is optional and only used in examples dnl GTK is optional and only used in examples
HAVE_GTK=no HAVE_GTK=no
HAVE_GTK_X11=no HAVE_GTK_X11=no
GTK2_REQ=2.14.0 GTK_REQ=3.0.0
GTK3_REQ=2.91.3
if test "x$BUILD_EXAMPLES" = "xyes"; then if test "x$BUILD_EXAMPLES" = "xyes"; then
AC_MSG_CHECKING([which gtk+ version to compile examples against (optional)]) PKG_CHECK_MODULES(GTK, gtk+-3.0 >= $GTK_REQ, HAVE_GTK=yes, HAVE_GTK=no)
AC_ARG_WITH([gtk],
AC_HELP_STRING([--with-gtk=3.0|2.0],
[which gtk+ version to compile against (default: 2.0)]),
[case "$with_gtk" in
2.0) GTK_REQ=$GTK2_REQ ;;
3.0) GTK_REQ=$GTK3_REQ ;;
*) AC_MSG_ERROR([invalid gtk+ version specified]);;
esac],
[with_gtk=2.0
GTK_REQ=$GTK2_REQ])
AC_MSG_RESULT([$with_gtk (>= $GTK_REQ)])
PKG_CHECK_MODULES(GTK, gtk+-$with_gtk >= $GTK_REQ, HAVE_GTK=yes, HAVE_GTK=no)
dnl some examples need gtk+-x11 dnl some examples need gtk+-x11
PKG_CHECK_MODULES(GTK_X11, gtk+-x11-$with_gtk >= $GTK_REQ, HAVE_GTK_X11=yes, HAVE_GTK_X11=no) PKG_CHECK_MODULES(GTK_X11, gtk+-x11-3.0 >= $GTK_REQ, HAVE_GTK_X11=yes, HAVE_GTK_X11=no)
AC_SUBST(GTK_LIBS) AC_SUBST(GTK_LIBS)
AC_SUBST(GTK_CFLAGS) AC_SUBST(GTK_CFLAGS)
fi fi
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment