Commit 6c8cc9be authored by Timothy Arceri's avatar Timothy Arceri
Browse files

glsl: default to compat shaders in compat profile

If the shader does not specify "core" or "compatibility" in shaders
above 1.40 we were defaulting these shaders to core shaders when
in a compat profile. Instead default to compat shaders.

This brings us inline with the behaviour of the binary drivers and
fixes a crash on start-up for the game Foundation.

Closes: mesa/mesa#3594

Fixes: c7e3d31b

 ("glsl: fix compat shaders in GLSL 1.40")
Reviewed-by: default avatarMarek Olšák <marek.olsak@amd.com>
Reviewed-by: Zoltán Böszörményi's avatarZoltán Böszörményi <zboszor@gmail.com>
Part-of: <mesa/mesa!6993>
parent 5692e2dd
......@@ -396,14 +396,13 @@ _mesa_glsl_parse_state::process_version_directive(YYLTYPE *locp, int version,
{
bool es_token_present = false;
bool compat_token_present = false;
bool core_token_present = false;
if (ident) {
if (strcmp(ident, "es") == 0) {
es_token_present = true;
} else if (version >= 150) {
if (strcmp(ident, "core") == 0) {
/* Accept the token. There's no need to record that this is
* a core profile shader since that's the only profile we support.
*/
core_token_present = true;
} else if (strcmp(ident, "compatibility") == 0) {
compat_token_present = true;
......@@ -444,7 +443,8 @@ _mesa_glsl_parse_state::process_version_directive(YYLTYPE *locp, int version,
this->compat_shader = compat_token_present ||
(this->ctx->API == API_OPENGL_COMPAT &&
this->language_version == 140) ||
this->language_version >= 140 &&
!core_token_present) ||
(!this->es_shader && this->language_version < 140);
bool supported = false;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment