Commit c89d75d0 authored by David Schleef's avatar David Schleef

REQUIREMENTS: Change the format to key/value, add a bunch of information,...

REQUIREMENTS: Change the format to key/value, add a bunch of information, remove a bunch of requirements that are for...

Original commit message from CVS:
* REQUIREMENTS: Change the format to key/value, add a bunch of
information, remove a bunch of requirements that are for
other GStreamer packages.
parent 898fe7a2
2007-03-17 David Schleef <ds@schleef.org>
* REQUIREMENTS: Change the format to key/value, add a bunch of
information, remove a bunch of requirements that are for
other GStreamer packages.
2007-03-17 David Schleef <ds@schleef.org> 2007-03-17 David Schleef <ds@schleef.org>
* REQUIREMENTS: Fix a few things. This file really needs a * REQUIREMENTS: Fix a few things. This file really needs a
......
...@@ -20,8 +20,31 @@ pkgconfig 0.9.0 or better (http://www.freedesktop.org/software/pkgconfig/) ...@@ -20,8 +20,31 @@ pkgconfig 0.9.0 or better (http://www.freedesktop.org/software/pkgconfig/)
Required libraries: Required libraries:
=================== ===================
The core GStreamer libraries. See the gstreamer/ module in GStreamer cvs, or Package: GStreamer
the version that corresponds to this plugin release. Version: 0.10.11.2
Recommended: 0.10.latest
URL: http://gstreamer.freedesktop.org/
DebianPackage: libgstreamer0.10-dev
Notes: The required version is updated frequently, so the version
listed in this file is often wrong. If you are compiling from CVS,
the required version is often the latest GStreamer CVS.
Package: GStreamer Base Plugins
Version: 0.10.11.2
Recommended: 0.10.latest
URL: http://gstreamer.freedesktop.org/
DebianPackage: libgstreamer-plugins-base0.10-dev
Notes: The required version is updated frequently, so the version
listed in this file is often wrong. If you are compiling from CVS,
the required version is often the latest GStreamer Base Plugins CVS.
Package: liboil
Version: >= 0.3.8
Recommended: 0.3.latest
URL: http://liboil.freedesktop.org/
DebianPackage: liboil0.3-dev
Optional libraries: Optional libraries:
=================== ===================
...@@ -30,86 +53,109 @@ This file lists supporting libraries for which gst-plugins contains plugins, ...@@ -30,86 +53,109 @@ This file lists supporting libraries for which gst-plugins contains plugins,
as well as their minimum version. You can find the corresponding plugins in as well as their minimum version. You can find the corresponding plugins in
ext/(library) ext/(library)
dirac (Dirac video codec) Package: GTK+
http://www.bbc.co.uk/rd/projects/dirac/index.shtml Version: >= 2.0
libaudiofile (for afsrc/afsink Recommended: >= 2.2
http://oss.sgi.com/projects/audiofile/ URL: http://www.gtk.org/
libmad (for the mad mp3 decoder plugin) DebianPackage: libgtk2.0-dev
http://www.mars.org/home/rob/proj/mpeg/ Plugins: gdkpixbuf (gdkpixbufdec, gdkpixbufscale)
libjpeg (for jpegenc/jpegdec) Notes: Also required by several examples. Plugin require >= 2.2.
http://www.ijg.org/
libopenquicktime (for the QT plugin) Package: Check
http://sourceforge.net/projects/openquicktime/ DebianPackage: check
libXv (for videosink) URL: http://check.sourceforge.net/
libxaudio (for xa mp3 decoder)
http://www.xaudio.com/ Package: Xlib
libvorbis (for vorbisenc, vorbisdec) Plugins: ximagesrc, v4l2
http://www.xiph.org/ogg/vorbis/index.html DebianPackage: libx11-dev libxv-dev libxt-dev
libcdparanoia (for cdparanoia ripper)
http://www.xiph.org/paranoia/index.html Package: AALib
liblame (for lame mp3 encoder) Plugins: aasink
http://www.mp3dev.org/mp3/ URL: http://aa-project.sourceforge.net/aalib/
libshout (for the shoutcast plugin)
http://www.icecast.org Package: LibXML
libasound (for the alsa src/sink plugin) Version: >= 2.4.9
http://alsa-project.org/ Plugins: annodex (cmmlenc, cmmldec)
librtp (for the rtp sink plugin) URL: http://xmlsoft.org/
http://www.linphone.org/ortp/
aalib (for the aa sink plugin) Package: Cairo
http://aa-project.sourceforge.net/aalib/ Version: >= 1.0
libcaca (for the color aa sink plugin) Plugins: cairo (cairotextoverlay, cairotimeoverlay)
http://sam.zoy.org/projects/libcaca/ URL: http://cairographics.org/
aRts (for the arts plugin wrapper, and the artsd sink)
http://www.arts-project.org Package: CDIO
raw1394/linux1394 (for the dv plugin) Version: >= 0.71
http://linux1394.sourceforge.net Plugins: cdio (cdiocddasrc)
libdvdread (for the dvdsrc) URL: http://www.gnu.org/software/libcdio/
http://www.dtek.chalmers.se/groups/dvd/
(optional: libcss for encrypted DVDs) Package: ESound
libdvdnav (for the dvdnavsrc) Version: >= 0.2.12
http://dvd.sourceforge.net/ Plugins: esdsink
(optional: libcss for encrypted DVDs) URL: http://www.gnome.org/
>= 0.1.9
libesound (for the esd sink Package: FLAC
ftp.gnome.org/pub/GNOME/stable/sources/esound) Version: == 1.1.2
gnome-vfs (for the gnome-vfs src) Plugins: flac (flacenc, flacdec)
>= 2.4.0 URL: http://flac.sourceforge.net/
libgsm (for the gsm plugin)
http://kbs.cs.tu-berlin.de/~jutta/toast.html Package: GConf
sdl (for the sdl sink) Version: >= 2.0
http://www.libsdl.org Plugins: gconfelements (gconfvideosink, gconfvideosrc, gconfaudiosink,
xmms (for the xmms plugins wrapper) gconfaudiosrc)
http://www.xmms.org URL: http://www.gnome.org/
mpeg2dec/a52dec (for mpeg2 related plugins and dvd playback)
http://libmpeg2.sourceforge.net/ Package: HAL
and http://liba52.sourceforge.net/ Version: >= 0.5.6
>= v0.3.1/v0.7.2 Plugins: halelements (halaudiosink, halaudiosrc)
liboil (for the liboil optimization library) URL: http://hal.freedesktop.org/
http://www.schleef.org/liboil/
>= 0.3.10 Package: IJG JPEG library
flac (for the FLAC lossless audio format) Plugins: jpeg (jpegenc, jpegdec, smokeenc, smokedec)
http://flac.sourceforge.net URL: http://www.ijg.org/
= 1.1.2 other versions will not work
gtk (for the gdk_pixbuf plugin) Package: LADSPA
http://www.gtk.org/ Plugins: ladspa
>= 2.2.1 preferred, 2.0 ok URL: http://www.ladspa.org/
pango (for the textoverlay plugins)
http://www.pango.org/ Package: Libcaca
dtsdec (for DTS audio decoding) Plugins: cacasink
http://www.videolan.org/libdca.html URL: http://libcaca.zoy.org/
divx (for divx decoding)
http://www.divx.com/divx/linux/ Package: Libdv
libmng (for mng animated image format encoding/decoding) Version: >= 0.100
http://gjuyn.xs4all.nl/libmng Plugins: dv (dvdec)
musepack (for musepack audio codec/format) URL: http://libdv.sourceforge.net/
(http://www.musepack.net/)
nas (for the NAS sound server sink) Package: Libpng
(http://radscan.com/nas.html) Version: >= 1.2
libmms (for MMS protocol support) Plugins: png (pngenc, pngdec)
(http://www.sf.net/projects/libmms) URL: http://www.libpng.org/pub/png/libpng.html
Package: libraw1394
Optional debian packages: Plugins: dv1394
========================= URL: http://www.linux1394.org/
gtk-doc-tools 0.4-0.2 -- needed to build documentation Package: libiec61883
Plugins: dv1394
URL: http://www.linux1394.org/
Package: libshout
Version: >= 2.0
URL: http://www.icecast.org/
Package: speex
Version: >= 1.0.4 or >= 1.1.5
Plugins: speex (speexenc, speexdec)
URL: http://www.speex.org/
Package: taglib
Version: >= 1.4
DebianPackage: libtag1-dev
URL: http://developer.kde.org/~wheeler/taglib.html
Package: zlib
Plugins: id3demux
URL: http://www.zlib.net/
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment