Commit 39785d9c authored by Andreas Frisch's avatar Andreas Frisch Committed by Sebastian Dröge

pngdec: fix build with libpng versions between 1.2 and 1.5.1 (revised)

https://bugzilla.gnome.org/show_bug.cgi?id=765927
parent 5615ec59
......@@ -702,7 +702,7 @@ translit(dnm, m, l) AM_CONDITIONAL(USE_LIBPNG, true)
AG_GST_CHECK_FEATURE(LIBPNG, [Portable Network Graphics library], png, [
AG_GST_PKG_CHECK_MODULES(LIBPNG, libpng >= 1.2)
if test $HAVE_LIBPNG = "yes"; then
PKG_CHECK_MODULES(LIBPNG, libpng >= 1.5.1, [
PKG_CHECK_MODULES(LIBPNG_1_5, libpng >= 1.5.1, [
AC_DEFINE(HAVE_LIBPNG_1_5, 1, [Defined if libpng version is 1.5.1 or newer])
], [true])
fi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment