Fix Python 3.8 compatibility

From Python 3.8 and onwards, C extensions are no longer
linked to libpython so in order to embed python within
an application the --embed flag needs to be added to
python3-config --libs. A fall back is provided as the
command will error out on previous python versions.

References: https://bugs.python.org/issue36721
14 jobs for py38 in 46 minutes and 24 seconds (queued for 3 seconds)
latest
Status Job ID Name Coverage
  Preparation
passed #349339
gst indent

00:00:17

passed #349338
manifest

00:00:41

 
  Build
passed #349340
build fedora x86_64

00:07:32

passed #349341
build nodebug fedora x86_64

00:04:37

passed #349342
build static fedora x86_64

00:09:18

passed #349343
build static nodebug fedora x86_64

00:12:58

 
  Test
passed #349344
check fedora

00:03:35

passed #349345
integration testsuites fedora

00:08:29

 
  Full Builds
passed #349347
build cerbero android universal

00:15:51

passed #349348
build cerbero cross win32

00:11:50

passed #349349
build cerbero cross win64

00:05:54

passed #349346
build cerbero fedora x86_64

00:05:38

passed #349350
gst-macos-10.14
build cerbero macos x86_64

00:06:31

 
  Apps
passed #349351
android universal examples

00:06:12