Commit 03d46e9e authored by Christophe Fergeau's avatar Christophe Fergeau

build-sys: Raise glib requirement to 2.38

meson is already using 2.38, and most distros have a newer version:
    - Fedora 28 has 2.56
    - CentOS 7 has 2.46
    - Debian 9 has 2.50

This also matches what spice-common requires.
Signed-off-by: Christophe Fergeau's avatarChristophe Fergeau <cfergeau@redhat.com>
Acked-by: 's avatarEduardo Lima (Etrunko) <etrunko@redhat.com>
Acked-by: Frediano Ziglio's avatarFrediano Ziglio <fziglio@redhat.com>
parent 59f0efb5
......@@ -165,8 +165,8 @@ SPICE_PROTOCOL_MIN_VER=0.12.16
PKG_CHECK_MODULES([SPICE_PROTOCOL], [spice-protocol >= $SPICE_PROTOCOL_MIN_VER])
AC_SUBST([SPICE_PROTOCOL_MIN_VER])
GLIB2_REQUIRED=2.32
GLIB2_ENCODED_VERSION="GLIB_VERSION_2_32"
GLIB2_REQUIRED=2.38
GLIB2_ENCODED_VERSION="GLIB_VERSION_2_38"
PKG_CHECK_MODULES([GLIB2], [glib-2.0 >= $GLIB2_REQUIRED gio-2.0 >= $GLIB2_REQUIRED])
GLIB2_CFLAGS="$GLIB2_CFLAGS -DGLIB_VERSION_MIN_REQUIRED=$GLIB2_ENCODED_VERSION \
-DGLIB_VERSION_MAX_ALLOWED=$GLIB2_ENCODED_VERSION"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment