Commit 3a760f3d authored by Snir Sheriber's avatar Snir Sheriber

gst-plugin: build gst-plugin by default

And add the build requirements to spec file.
Signed-off-by: Snir Sheriber's avatarSnir Sheriber <ssheribe@redhat.com>
Acked-by: Francesco Giudici's avatarFrancesco Giudici <fgiudici@redhat.com>
parent 70f9edac
Pipeline #109187 passed with stage
in 4 minutes and 56 seconds
......@@ -65,7 +65,7 @@ AC_SUBST(UDEVRULESDIR)
AC_ARG_ENABLE([gst-plugin],
AS_HELP_STRING([--enable-gst-plugin=@<:@auto/yes/no@:>@],
[Enable GStreamer based plugin]),,
[enable_gst_plugin="no"])
[enable_gst_plugin="yes"])
if test "$enable_gst_plugin" != "no"; then
PKG_CHECK_MODULES(GST, [gstreamer-1.0 gstreamer-app-1.0], [enable_gst_plugin=yes],
[if test "$enable_gst_plugin" = "yes"; then
......
......@@ -15,6 +15,8 @@ BuildRequires: libdrm-devel
BuildRequires: libXrandr-devel
BuildRequires: gcc-c++
BuildRequires: diffutils
BuildRequires: gstreamer1-devel
BuildRequires: gstreamer1-plugins-base-devel
# we need /usr/sbin/semanage program which is available on different
# packages depending on distribution
Requires(post): /usr/sbin/semanage
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment