Silence deprecation warnings for PopplerAttachment->ctime, ->mtime

GTime is not Y2038-safe, and is now marked as deprecated. Don't trigger
deprecation warnings for projects that include poppler headers but
do not otherwise use GTime.

Part of #765.

Signed-off-by: Simon McVittie <smcv@debian.org>
6 jobs for silence-gtime-deprecation in 8 minutes and 18 seconds (queued for 1 second)
latest
Status Job ID Name Coverage
  Build
passed #695907
build

00:03:39

passed #695912
build_android

00:01:06

passed #695908
build_clang_libcpp

00:04:01

passed #695911
build_clazy

00:08:17

passed #695910
build_mingw64_fedora

00:03:27

passed #695909
build_ubuntu_16_04

00:02:10