Commit 307238b8 authored by Sebastian Dröge's avatar Sebastian Dröge 🍵

Update versions of everything and use releases instead of GIT

parent d768b081
......@@ -6,12 +6,12 @@ repository = "https://github.com/sdroege/gst-plugin-rs"
license = "MIT/Apache-2.0"
[dependencies]
gobject-subclass = { git = "https://github.com/gtk-rs/gobject-subclass" }
gst-plugin = { path="../gst-plugin" }
glib = { git = "https://github.com/gtk-rs/glib" }
gstreamer = { git = "https://github.com/sdroege/gstreamer-rs" }
gstreamer-base = { git = "https://github.com/sdroege/gstreamer-rs" }
gstreamer-audio = { git = "https://github.com/sdroege/gstreamer-rs" }
gobject-subclass = "0.2"
gst-plugin = { version = "0.3", path="../gst-plugin" }
glib = "0.6"
gstreamer = "0.12"
gstreamer-base = "0.12"
gstreamer-audio = "0.12"
byte-slice-cast = "0.2"
num-traits = "0.2"
......
......@@ -7,9 +7,9 @@ license = "MIT/Apache-2.0"
[dependencies]
url = "1.1"
gst-plugin = { path="../gst-plugin" }
gst-plugin-simple = { path="../gst-plugin-simple" }
gstreamer = { git = "https://github.com/sdroege/gstreamer-rs" }
gst-plugin = { version = "0.3", path="../gst-plugin" }
gst-plugin-simple = { version = "0.3", path="../gst-plugin-simple" }
gstreamer = "0.12"
[lib]
name = "gstrsfile"
......
......@@ -7,9 +7,9 @@ license = "MIT/Apache-2.0"
[dependencies]
url = "1.1"
gst-plugin = { path="../gst-plugin" }
gst-plugin-simple = { path="../gst-plugin-simple" }
gstreamer = { git = "https://github.com/sdroege/gstreamer-rs" }
gst-plugin = { version = "0.3", path="../gst-plugin" }
gst-plugin-simple = { version = "0.3", path="../gst-plugin-simple" }
gstreamer = "0.12"
num-rational = { version = "0.2", default-features = false, features = [] }
nom = "3.0"
flavors = {git = "https://github.com/rust-av/flavors.git"}
......
......@@ -7,10 +7,10 @@ license = "MIT/Apache-2.0"
[dependencies]
url = "1.1"
gst-plugin = { path="../gst-plugin" }
gst-plugin-simple = { path="../gst-plugin-simple" }
gst-plugin = { version = "0.3", path="../gst-plugin" }
gst-plugin-simple = { version = "0.3", path="../gst-plugin-simple" }
reqwest = "0.8"
gstreamer = { git = "https://github.com/sdroege/gstreamer-rs" }
gstreamer = "0.12"
[lib]
name = "gstrshttp"
......
......@@ -7,11 +7,11 @@ license = "MIT/Apache-2.0"
[dependencies]
url = "1.1"
glib = { git = "https://github.com/gtk-rs/glib" }
gobject-subclass = { git = "https://github.com/gtk-rs/gobject-subclass" }
gst-plugin = { path="../gst-plugin" }
gstreamer = { git = "https://github.com/sdroege/gstreamer-rs" }
gstreamer-base = { git = "https://github.com/sdroege/gstreamer-rs" }
glib = "0.6"
gobject-subclass = "0.2"
gst-plugin = { version = "0.3", path="../gst-plugin" }
gstreamer = "0.12"
gstreamer-base = "0.12"
[lib]
name = "gst_plugin_simple"
......
......@@ -5,13 +5,13 @@ authors = ["Sebastian Dröge <sebastian@centricular.com>"]
license = "LGPL-2.1+"
[dependencies]
glib = { git = "https://github.com/gtk-rs/glib" }
gstreamer = { git = "https://github.com/sdroege/gstreamer-rs" }
gstreamer-video = { git = "https://github.com/sdroege/gstreamer-rs" }
gobject-subclass = { git = "https://github.com/gtk-rs/gobject-subclass" }
gst-plugin = { path = "../gst-plugin" }
gtk = { git = "https://github.com/gtk-rs/gtk", features = ["v3_6"], optional = true }
gio = { git = "https://github.com/gtk-rs/gio", optional = true }
glib = "0.6"
gstreamer = "0.12"
gstreamer-video = "0.12"
gobject-subclass = "0.2"
gst-plugin = { version = "0.3", path = "../gst-plugin" }
gtk = { version = "0.5", features = ["v3_6"], optional = true }
gio = { version = "0.5", optional = true }
[dev-dependencies]
either = "1.0"
......
......@@ -6,13 +6,13 @@ repository = "https://github.com/sdroege/gst-plugin-rs"
license = "MIT/Apache-2.0"
[dependencies]
gobject-subclass = { git = "https://github.com/gtk-rs/gobject-subclass" }
gst-plugin = { path="../gst-plugin" }
glib = { git = "https://github.com/gtk-rs/glib" }
gstreamer = { git = "https://github.com/sdroege/gstreamer-rs" }
gstreamer-base = { git = "https://github.com/sdroege/gstreamer-rs" }
gstreamer-video = { git = "https://github.com/sdroege/gstreamer-rs" }
gstreamer-audio = { git = "https://github.com/sdroege/gstreamer-rs" }
gobject-subclass = "0.2"
gst-plugin = { version = "0.3", path="../gst-plugin" }
glib = "0.6"
gstreamer = "0.12"
gstreamer-base = "0.12"
gstreamer-video = "0.12"
gstreamer-audio = "0.12"
byte-slice-cast = "0.2"
num-traits = "0.2"
......
......@@ -15,14 +15,14 @@ keywords = ["gstreamer", "multimedia", "audio", "video", "gnome"]
libc = "0.2"
lazy_static = "1.0"
byteorder = "1.0"
gobject-subclass = { git = "https://github.com/gtk-rs/gobject-subclass" }
glib-sys = { git = "https://github.com/gtk-rs/sys" }
gobject-sys = { git = "https://github.com/gtk-rs/sys" }
gstreamer-sys = { git = "https://github.com/sdroege/gstreamer-sys" }
gstreamer-base-sys = { git = "https://github.com/sdroege/gstreamer-sys" }
glib = { git = "https://github.com/gtk-rs/glib" }
gstreamer = { git = "https://github.com/sdroege/gstreamer-rs" }
gstreamer-base = { git = "https://github.com/sdroege/gstreamer-rs" }
gobject-subclass = "0.2"
glib-sys = "0.7"
gobject-sys = "0.7"
gstreamer-sys = "0.6"
gstreamer-base-sys = "0.6"
glib = "0.6"
gstreamer = "0.12"
gstreamer-base = "0.12"
[lib]
name = "gst_plugin"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment