Commit 67f2be19 authored by Nirbheek Chauhan's avatar Nirbheek Chauhan 🐜
Browse files

meson: Maintain macOS ABI through dylib versioning

Requires Meson 0.48, but the feature will be ignored on older versions
so it's safe to add it without bumping the requirement.

Documentation:
https://github.com/mesonbuild/meson/blob/master/docs/markdown/Reference-manual.md#shared_library
parent 6a806a0d
......@@ -158,6 +158,7 @@ parser = custom_target('gesparselex',
libges = shared_library('ges-1.0', ges_sources, parser,
version : libversion,
soversion : soversion,
darwin_versions : osxversion,
c_args : [ges_c_args],
include_directories : [configinc],
install : true,
......
......@@ -21,7 +21,9 @@ apiversion = '1.0'
soversion = 0
# maintaining compatibility with the previous libtool versioning
# current = minor * 100 + micro
libversion = '@0@.@1@.0'.format(soversion, gst_version_minor * 100 + gst_version_micro)
curversion = gst_version_minor * 100 + gst_version_micro
libversion = '@0@.@1@.0'.format(soversion, curversion)
osxversion = curversion + 1
glib_req = '>= 2.40.0'
gst_req = '>= @0@.@1@.0'.format(gst_version_major, gst_version_minor)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment