Commit a1a6f23e authored by Pino Toscano's avatar Pino Toscano

[CMake] correctly set the GLIB_REQ stuff

parent 0f2e5d69
......@@ -87,6 +87,7 @@ if(CAIRO_FOUND)
set(CAIRO_REQ "cairo")
macro_optional_find_package(GTK)
if(GLIB_FOUND)
set(GLIB_REQ "glib-2.0 >= ${GLIB_VERSION} gobject-2.0 >= ${GLIB_VERSION} cairo >= ${CAIRO_VERSION}")
if(GDK_FOUND)
set(GDK_REQ "gdk-2.0 gdk-pixbuf-2.0")
set(POPPLER_WITH_GDK ${GDK_FOUND})
......
......@@ -6,7 +6,7 @@ includedir=${prefix}/include
Name: poppler-glib
Description: GLib wrapper for poppler
Version: @POPPLER_VERSION@
Requires: poppler-cairo = @POPPLER_VERSION@ gobject-2.0 @GDK_REQ@
Requires: poppler-cairo = @POPPLER_VERSION@ @GLIB_REQ@ @GDK_REQ@
@PC_REQUIRES_PRIVATE@
Libs: -L${libdir} -lpoppler-glib
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment