Commit 50adbed1 authored by Carlos Garcia Campos's avatar Carlos Garcia Campos

Remove poppler-cairo dependency from poppler-glib pkg-config file

poppler-glib links to poppler-cairo statically, so it doesn'tm depend on
the dynamic library.
parent acd8ecc9
......@@ -93,7 +93,6 @@ if(CAIRO_FOUND)
# Check for introspection
macro_optional_find_package(GObjectIntrospection 0.9.12)
set(HAVE_INTROSPECTION ${INTROSPECTION_FOUND})
set(GLIB_REQ "glib-2.0 >= ${GLIB_REQUIRED} gobject-2.0 >= ${GLIB_REQUIRED} cairo >= ${CAIRO_VERSION}")
set(POPPLER_GLIB_DISABLE_DEPRECATED "${POPPLER_GLIB_DISABLE_DEPRECATED} -DG_DISABLE_DEPRECATED")
set(POPPLER_GLIB_DISABLE_SINGLE_INCLUDES "${POPPLER_GLIB_DISABLE_SINGLE_INCLUDES} -DG_DISABLE_SINGLE_INCLUDES")
macro_optional_find_package(GTK)
......
......@@ -425,7 +425,6 @@ if test x$enable_cairo_output = xyes; then
# Check for introspection
GOBJECT_INTROSPECTION_CHECK([0.6.7])
GLIB_REQ="glib-2.0 >= $GLIB_REQUIRED gobject-2.0 >= $GLIB_REQUIRED cairo >= $CAIRO_VERSION"
AC_PATH_PROG([GLIB_MKENUMS],[glib-mkenums])
POPPLER_GLIB_DISABLE_DEPRECATED="$POPPLER_GLIB_DISABLE_DEPRECATED -DG_DISABLE_DEPRECATED"
POPPLER_GLIB_DISABLE_SINGLE_INCLUDES="$POPPLER_GLIB_DISABLE_SINGLE_INCLUDES -DG_DISABLE_SINGLE_INCLUDES"
......@@ -435,7 +434,6 @@ else
AC_MSG_ERROR("Cairo output is required to build glib frontend")
fi
enable_poppler_glib="no"
GLIB_REQ=""
fi
AM_CONDITIONAL(BUILD_POPPLER_GLIB, test x$enable_poppler_glib = xyes)
AM_CONDITIONAL(HAVE_INTROSPECTION, test "x$found_introspection" = "xyes")
......
Name: poppler-glib
Description: GLib wrapper for poppler - uninstalled
Version: @VERSION@
Requires: poppler-cairo = @VERSION@ @GLIB_REQ@
Requires: glib-2.0 >= $GLIB_REQUIRED gobject-2.0 >= $GLIB_REQUIRED cairo >= $CAIRO_VERSION
Libs: ${pc_top_builddir}/${pcfiledir}/glib/libpoppler-glib.la
Cflags: -I${pc_top_builddir}/${pcfiledir}/glib
......@@ -6,7 +6,7 @@ includedir=${prefix}/include
Name: poppler-glib
Description: GLib wrapper for poppler
Version: @POPPLER_VERSION@
Requires: poppler-cairo = @POPPLER_VERSION@ @GLIB_REQ@
Requires: glib-2.0 >= $GLIB_REQUIRED gobject-2.0 >= $GLIB_REQUIRED cairo >= $CAIRO_VERSION
@PC_REQUIRES_PRIVATE@
Libs: -L${libdir} -lpoppler-glib
......
......@@ -6,7 +6,7 @@ includedir=@includedir@
Name: poppler-glib
Description: GLib wrapper for poppler
Version: @VERSION@
Requires: poppler-cairo = @VERSION@ @GLIB_REQ@
Requires: glib-2.0 >= $GLIB_REQUIRED gobject-2.0 >= $GLIB_REQUIRED cairo >= $CAIRO_VERSION
@PC_REQUIRES_PRIVATE@
Libs: -L${libdir} -lpoppler-glib
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment