Commit 76818651 authored by Martin Kretzschmar's avatar Martin Kretzschmar

require glib 2.4+ for g_value_take_string and G_DEFINE_TYPE.

parent 5d40e34a
2005-06-26 Martin Kretzschmar <martink@gnome.org>
* configure.ac: require glib 2.4+ for g_value_take_string and
G_DEFINE_TYPE.
2005-06-25 Jeff Muizelaar <jeff@infidigm.net>
* poppler/Error.h: Maybe fix build on Solaris.
......
......@@ -202,9 +202,9 @@ AC_ARG_ENABLE(poppler-glib,
enable_poppler_glib=$enableval,
enable_poppler_glib="try")
if test x$enable_poppler_glib = xyes; then
PKG_CHECK_MODULES(POPPLER_GLIB, gdk-pixbuf-2.0 fontconfig)
PKG_CHECK_MODULES(POPPLER_GLIB, gdk-pixbuf-2.0 glib-2.0 >= 2.4.0 fontconfig)
elif test x$enable_poppler_glib = xtry; then
PKG_CHECK_MODULES(POPPLER_GLIB, gdk-pixbuf-2.0 fontconfig,
PKG_CHECK_MODULES(POPPLER_GLIB, gdk-pixbuf-2.0 glib-2.0 >= 2.4.0 fontconfig,
[enable_poppler_glib="yes"],
[enable_poppler_glib="no"])
fi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment