Commit b943caa1 authored by Arun Raghavan's avatar Arun Raghavan

build-sys: Update meson dependency to 0.50.0

This is needed for currently used features (disabler and install in
configure_file).
parent 2f6a46ca
Pipeline #31295 passed with stage
in 3 minutes and 54 seconds
project('pulseaudio', 'c', 'cpp',
version : run_command(find_program('git-version-gen'), join_paths(meson.current_source_dir(), '.tarball-version')).stdout().strip(),
meson_version : '>= 0.47.0',
meson_version : '>= 0.50.0',
default_options : [ 'c_std=gnu11', 'cpp_std=c++11' ]
)
......@@ -250,7 +250,7 @@ if get_option('database') == 'tdb'
elif get_option('database') == 'gdbm'
database_dep = cc.find_library('gdbm', required : true)
else
database_dep = dependency('', required:false)
database_dep = dependency('', required: false)
endif
if get_option('ipv6')
......
......@@ -43,10 +43,11 @@ RUN apt-get update && apt-get install -y \
libxtst-dev \
make \
ninja-build \
python3-setuptools \
systemd
# Install meson from upstream tarball
ARG MESON_VERSION=0.47.0
ARG MESON_VERSION=0.50.0
RUN apt-get install -y wget && \
wget -q https://github.com/mesonbuild/meson/releases/download/${MESON_VERSION}/meson-${MESON_VERSION}.tar.gz && \
tar -xf meson-${MESON_VERSION}.tar.gz && \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment