Stop requiring gcc 4.9

We now just support whatever Ubuntu 16.04 has as minimum (gcc 5.4.0)
10 jobs for master in 50 minutes and 44 seconds (queued for 4 seconds)
Status Name Job ID Coverage
  Build
passed build #186797

00:04:43

passed build_android #186802

00:03:26

passed build_clang_libcpp #186798

00:04:47

passed build_clazy #186801

00:38:43

passed build_mingw64_fedora #186800

00:18:48

passed build_ubuntu_16_04 #186799

00:05:32

 
  Document
passed cpp_docs #186804

00:05:42

passed glib_docs #186805

00:05:52

passed qt5_docs #186803

00:05:58

 
  Publish
passed trigger_pages #186806

00:00:22