Commit c317087a authored by Albert Astals Cid's avatar Albert Astals Cid Committed by Albert Astals Cid
Browse files

Stop requiring gcc 4.9

We now just support whatever Ubuntu 16.04 has as minimum (gcc 5.4.0)
parent 9068f1c0
Pipeline #25519 passed with stages
in 50 minutes and 44 seconds
...@@ -44,21 +44,12 @@ build_clang_libcpp: ...@@ -44,21 +44,12 @@ build_clang_libcpp:
- ninja - ninja
- ctest --output-on-failure - ctest --output-on-failure
build_gcc_49: build_ubuntu_16_04:
stage: build stage: build
image: ubuntu:trusty image: ubuntu:xenial
before_script: before_script:
- apt-get update - apt-get update
- apt-get install --yes software-properties-common - apt-get install --yes --no-install-recommends build-essential cmake ninja-build libjpeg-dev libopenjp2-7-dev qtbase5-dev gobject-introspection libglib2.0-dev libgtk-3-dev libgirepository1.0-dev libnss3-dev ca-certificates
- add-apt-repository --yes ppa:ubuntu-toolchain-r/test
- add-apt-repository --yes ppa:george-edison55/cmake-3.x
- add-apt-repository --yes ppa:ricotz/testing
- add-apt-repository --yes ppa:aacid/openjp2trusty
- apt-get update
- apt-get install --yes build-essential cmake ninja-build gcc-4.9 g++-4.9 libjpeg-dev libopenjp2-7-dev qtbase5-dev gobject-introspection libglib2.0-dev libgtk-3-dev libgirepository1.0-dev libnss3-dev
- update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.9 20
- update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-4.9 20
- update-alternatives --install /usr/bin/gcov gcov /usr/bin/gcov-4.9 20
script: script:
- mkdir -p build && cd build - mkdir -p build && cd build
- cmake -G Ninja .. - cmake -G Ninja ..
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment