Commit 1ad3bc82 authored by Albert Astals Cid's avatar Albert Astals Cid
Browse files

CI: Use debian:unstable instead of fedora:31 that has a newer clazy

clazy is broken in fedora 32 and 33 and i'm tired of complaining
parent 6d7ed61d
Pipeline #220549 failed with stages
in 15 minutes and 32 seconds
......@@ -82,12 +82,8 @@ build_mingw64_fedora:
build_clazy:
stage: build
image: fedora:31
before_script:
- dnf install -y 'dnf-command(builddep)'
- dnf builddep -y poppler
- dnf -y install glibc-langpack-en make ninja-build clazy clang redhat-rpm-config libcurl-devel
script:
- apt-get install --yes --no-install-recommends clazy
- mkdir -p build && cd build
- CC=clang CXX=clazy CXXFLAGS="-Werror -Wno-deprecated-declarations" cmake -G Ninja ..
- CLAZY_CHECKS="level0,level1,level2,isempty-vs-count,qhash-with-char-pointer-key,tr-non-literal,no-non-pod-global-static" ninja
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment