Commit 0e312f8c authored by Arkadiusz Hiler's avatar Arkadiusz Hiler
Browse files

Move over to Python 3.7



Celery 4.3 is compatible with Python 3.7
Signed-off-by: default avatarArkadiusz Hiler <arkadiusz.hiler@intel.com>
parent 154ae850
Pipeline #47734 passed with stages
in 7 minutes and 10 seconds
FROM python:3.6
FROM python:3.7
ENV DEBIAN_FRONTEND noninteractive
......
......@@ -4,5 +4,5 @@ drf-nested-routers
enum34
jsonfield
django-filter>=1.1.0,<1.2.0
celery>=4.0,<5.0
celery>=4.3,<5.0
redis
[tox]
minversion = 1.6
envlist = py{27,36}-django111, pep8
envlist = py{27,37}-django111, pep8
skipsdist = True
[testenv]
......@@ -18,7 +18,7 @@ commands =
{toxinidir}/manage.py test --parallel --noinput '{posargs:patchwork}'
[testenv:pep8]
basepython = python3.6
basepython = python3.7
deps = flake8
commands = flake8 {posargs:patchwork patchwork/bin/pwclient git-pw/git-pw}
......@@ -27,7 +27,7 @@ ignore = E121,E122,E123,E124,E125,E126,E127,E128,E129,E131,E203,E241,E251,E402,H
exclude = ./patchwork/migrations
[testenv:lint]
basepython = python3.6
basepython = python3.7
deps =
pylint
pylint-django
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment