Commit a66ffcd7 authored by Emil Velikov's avatar Emil Velikov Committed by Emil Velikov

configure.ac: Mandate --enable-gallium-llvm when checking LLVM version

With this change we effectively require --enable-gallium-llvm when
building RADV. This should be perfectly safe since the gallium radeonsi
driver already explicitly requires it.

The "gallium" part in --enable-gallium-llvm is about to be removed soon
(not in stable), but until then make sure that things can build.

To reflect the requirement (as opposed to check previously) we rename
llvm_check_version_for to llvm_require_version

Cc: Dave Airlie <airlied@redhat.com>
Cc: "17.0" <mesa-stable@lists.freedesktop.org>
Signed-off-by: 's avatarEmil Velikov <emil.velikov@collabora.com>
Reviewed-by: 's avatarTobias Droste <tdroste@gmx.de>
parent 514a4944
......@@ -973,11 +973,12 @@ require_llvm() {
fi
}
llvm_check_version_for() {
llvm_require_version() {
if test "x$MESA_LLVM" = x0; then
AC_MSG_ERROR([LLVM $1 or newer is required for $2])
return
fi
require_llvm $2
llvm_target_version_major=`echo $1 | cut -d. -f1 | egrep -o '^[[0-9]]+'`
llvm_target_version_minor=`echo $1 | cut -d. -f2 | egrep -o '^[[0-9]]+'`
......@@ -1018,7 +1019,7 @@ radeon_llvm_check() {
amdgpu_llvm_target_name='amdgpu'
fi
llvm_check_version_for $*
llvm_require_version $*
llvm_add_target $amdgpu_llvm_target_name $2
......@@ -2030,7 +2031,7 @@ if test "x$enable_opencl" = xyes; then
AC_MSG_ERROR([Clover requires libelf])
fi
llvm_check_version_for $LLVM_REQUIRED_OPENCL "opencl"
llvm_require_version $LLVM_REQUIRED_OPENCL "opencl"
llvm_add_default_components "opencl"
llvm_add_component "all-targets" "opencl"
......@@ -2341,8 +2342,7 @@ if test -n "$with_gallium_drivers"; then
fi
;;
xswr)
llvm_check_version_for $LLVM_REQUIRED_SWR "swr"
require_llvm "swr"
llvm_require_version $LLVM_REQUIRED_SWR "swr"
swr_require_cxx_feature_flags "C++11" "__cplusplus >= 201103L" \
",-std=c++11" \
......@@ -2384,7 +2384,7 @@ if test -n "$with_gallium_drivers"; then
fi
if test "x$enable_gallium_llvm" == "xyes"; then
llvm_check_version_for $LLVM_REQUIRED_GALLIUM "gallium"
llvm_require_version $LLVM_REQUIRED_GALLIUM "gallium"
llvm_add_default_components "gallium"
fi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment