Commit 723b7839 authored by Andreas Boll's avatar Andreas Boll Committed by Chad Versace

configure.ac: Allow OpenGL ES1 and ES2 only with enabled OpenGL

Building OpenGL ES1 and/or ES2 without OpenGL is not supported on mesa
9.0.x
Reviewed-by: 's avatarChad Versace <chad.versace@linux.intel.com>
parent 7be536bb
......@@ -676,6 +676,17 @@ if test "x$enable_opengl" = xno -a \
AC_MSG_ERROR([at least one API should be enabled])
fi
# Building OpenGL ES1 and/or ES2 without OpenGL is not supported on mesa 9.0.x
if test "x$enable_opengl" = xno -a \
"x$enable_gles1" = xyes; then
AC_MSG_ERROR([Building OpenGL ES1 without OpenGL is not supported])
fi
if test "x$enable_opengl" = xno -a \
"x$enable_gles2" = xyes; then
AC_MSG_ERROR([Building OpenGL ES2 without OpenGL is not supported])
fi
API_DEFINES=""
if test "x$enable_opengl" = xno; then
API_DEFINES="$API_DEFINES -DFEATURE_GL=0"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment