Commit 4fc0ebdf authored by Stefan Schake's avatar Stefan Schake Committed by Eric Anholt

broadcom/vc4: Bump libdrm requirement

Require a version of libdrm with syncobj support.

v2: Don't require a libdrm_vc4, just bump core libdrm if vc4 enabled (by
    anholt)
Signed-off-by: Stefan Schake's avatarStefan Schake <stschake@gmail.com>
Reviewed-by: Eric Anholt's avatarEric Anholt <eric@anholt.net>
parent 580d1f4c
...@@ -80,6 +80,7 @@ LIBDRM_NVVIEUX_REQUIRED=2.4.66 ...@@ -80,6 +80,7 @@ LIBDRM_NVVIEUX_REQUIRED=2.4.66
LIBDRM_NOUVEAU_REQUIRED=2.4.66 LIBDRM_NOUVEAU_REQUIRED=2.4.66
LIBDRM_FREEDRENO_REQUIRED=2.4.92 LIBDRM_FREEDRENO_REQUIRED=2.4.92
LIBDRM_ETNAVIV_REQUIRED=2.4.89 LIBDRM_ETNAVIV_REQUIRED=2.4.89
LIBDRM_VC4_REQUIRED=2.4.89
dnl Versions for external dependencies dnl Versions for external dependencies
DRI2PROTO_REQUIRED=2.8 DRI2PROTO_REQUIRED=2.8
...@@ -2727,6 +2728,7 @@ if test -n "$with_gallium_drivers"; then ...@@ -2727,6 +2728,7 @@ if test -n "$with_gallium_drivers"; then
;; ;;
xvc4) xvc4)
HAVE_GALLIUM_VC4=yes HAVE_GALLIUM_VC4=yes
PKG_CHECK_MODULES([VC4], [libdrm >= $LIBDRM_VC4_REQUIRED])
PKG_CHECK_MODULES([SIMPENROSE], [simpenrose], PKG_CHECK_MODULES([SIMPENROSE], [simpenrose],
[USE_VC4_SIMULATOR=yes; [USE_VC4_SIMULATOR=yes;
......
...@@ -1055,6 +1055,12 @@ _libdrm_checks = [ ...@@ -1055,6 +1055,12 @@ _libdrm_checks = [
['freedreno', with_gallium_freedreno], ['freedreno', with_gallium_freedreno],
] ]
# VC4 only needs core libdrm support of this version, not a libdrm_vc4
# library.
if with_gallium_vc4
_drm_ver = '2.4.89'
endif
# Loop over the enables versions and get the highest libdrm requirement for all # Loop over the enables versions and get the highest libdrm requirement for all
# active drivers. # active drivers.
foreach d : _libdrm_checks foreach d : _libdrm_checks
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment