Commit 2c72e78f authored by Emil Velikov's avatar Emil Velikov Committed by Emil Velikov

autoconf/scons: bump libdrm to 2.4.75

We'll be using the drmGetDevice[s]2 API in src/loader with next patch.

v2: Rebase.
Signed-off-by: 's avatarEmil Velikov <emil.velikov@collabora.com>
Reviewed-by: Michel Dänzer <michel.daenzer@amd.com> (v1)
Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com> (v1)
Tested-by: Mike Lothian's avatarMike Lothian <mike@fireburn.co.uk>
parent 0fd61fb6
......@@ -72,7 +72,7 @@ AC_SUBST([OPENCL_VERSION])
# codifies which drivers need which version of libdrm. Any libdrm
# version dependencies in non-driver-specific code should be reflected
# in the first entry.
LIBDRM_REQUIRED=2.4.66
LIBDRM_REQUIRED=2.4.75
LIBDRM_RADEON_REQUIRED=2.4.71
LIBDRM_AMDGPU_REQUIRED=2.4.63
LIBDRM_INTEL_REQUIRED=2.4.75
......
......@@ -648,7 +648,7 @@ def generate(env):
env.PkgCheckModules('X11', ['x11', 'xext', 'xdamage >= 1.1', 'xfixes', 'glproto >= 1.4.13', 'dri2proto >= 2.8'])
env.PkgCheckModules('XCB', ['x11-xcb', 'xcb-glx >= 1.8.1', 'xcb-dri2 >= 1.8'])
env.PkgCheckModules('XF86VIDMODE', ['xxf86vm'])
env.PkgCheckModules('DRM', ['libdrm >= 2.4.66'])
env.PkgCheckModules('DRM', ['libdrm >= 2.4.75'])
if env['x11']:
env.Append(CPPPATH = env['X11_CPPPATH'])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment