Commit 0cef0ccc authored by Juan Suárez Romero's avatar Juan Suárez Romero

swr: bump minimum supported LLVM version to 6.0

RADV now requires LLVM 6.0 or greater, and thus we can't build dist
tarball because swr requires LLVM 5.0.

Let's bump required LLVM to 6.0 in swr too.

v2: bump also in meson.build (Eric)

Fixes: fd1121e8 ("amd: remove support for LLVM 5.0")
Cc: Tim Rowley <timothy.o.rowley@intel.com>
Cc: Emil Velikov <emil.velikov@collabora.com>
Cc: Dylan Baker <dylan@pnwbakers.com>
Cc: Eric Engestrom <eric.engestrom@intel.com>
Reviewed-by: Eric Engestrom's avatarEric Engestrom <eric.engestrom@intel.com>
Reviewed-by: Bruce Cherniak's avatarBruce Cherniak <bruce.cherniak@intel.com>
parent 25ec806e
......@@ -110,7 +110,7 @@ LLVM_REQUIRED_OPENCL=3.9.0
LLVM_REQUIRED_R600=3.9.0
LLVM_REQUIRED_RADEONSI=6.0.0
LLVM_REQUIRED_RADV=6.0.0
LLVM_REQUIRED_SWR=5.0.0
LLVM_REQUIRED_SWR=6.0.0
dnl Check for progs
AC_PROG_CPP
......@@ -2816,9 +2816,8 @@ if test -n "$with_gallium_drivers"; then
fi
# XXX: Keep in sync with LLVM_REQUIRED_SWR
AM_CONDITIONAL(SWR_INVALID_LLVM_VERSION, test "x$LLVM_VERSION" != x5.0.0 -a \
"x$LLVM_VERSION" != x5.0.1 -a \
"x$LLVM_VERSION" != x5.0.2)
AM_CONDITIONAL(SWR_INVALID_LLVM_VERSION, test "x$LLVM_VERSION" != x6.0.0 -a \
"x$LLVM_VERSION" != x6.0.1)
if test "x$enable_llvm" = "xyes" -a "$with_gallium_drivers"; then
llvm_require_version $LLVM_REQUIRED_GALLIUM "gallium"
......
......@@ -1160,7 +1160,7 @@ endif
if with_amd_vk or with_gallium_radeonsi
_llvm_version = '>= 6.0.0'
elif with_gallium_swr
_llvm_version = '>= 5.0.0'
_llvm_version = '>= 6.0.0'
elif with_gallium_opencl or with_gallium_r600
_llvm_version = '>= 3.9.0'
else
......
......@@ -375,7 +375,7 @@ include $(top_srcdir)/install-gallium-links.mk
dist-hook:
if SWR_INVALID_LLVM_VERSION
@echo "*****************************************"
@echo "LLVM 5.0.x required to create the tarball"
@echo "LLVM 6.0.x required to create the tarball"
@echo "*****************************************"
@test
endif
......
......@@ -12,8 +12,8 @@ if not env['llvm']:
env['swr'] = False
Return()
if env['LLVM_VERSION'] < distutils.version.LooseVersion('5.0'):
print("warning: swr requires LLVM >= 5.0: not building swr")
if env['LLVM_VERSION'] < distutils.version.LooseVersion('6.0'):
print("warning: swr requires LLVM >= 6.0: not building swr")
env['swr'] = False
Return()
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment