1. 16 May, 2017 23 commits
  2. 11 May, 2017 1 commit
  3. 09 May, 2017 6 commits
  4. 07 May, 2017 1 commit
  5. 06 May, 2017 1 commit
    • Masahiro Yamada's avatar
      docs: bump minimal GNU Make version to 3.81 · 37d69ee3
      Masahiro Yamada authored
      Since 2014, you can't successfully build kernels with GNU Make version
      3.80. Example errors:
      
        $ git describe
        v4.11
        $ make --version | head -1
        GNU Make 3.80
        $ make defconfig
          HOSTCC  scripts/basic/fixdep
        scripts/Makefile.host:135: *** missing separator.  Stop.
        make: *** [defconfig] Error 2
        $ make ARCH=arm64 help
        arch/arm64/Makefile:43: *** unterminated call to function `warning': missing `)'.  Stop.
        $ make help >/dev/null
        ./Documentation/Makefile.sphinx:25: Extraneous text after `else' directive
        ./Documentation/Makefile.sphinx:31: *** only one `else' per conditional.  Stop.
        make: *** [help] Error 2
      
      The first breakage was introduced by commit c8589d1e ("kbuild:
      handle multi-objs dependency appropriately").  Since then (i.e. v3.18),
      GNU Make 3.80 has not been able to compile the kernel, but nobody has
      ever complained aboutt (or noticed) it.
      
      Even GNU Make 3.81 is more than 10 years old.  It would not hurt to
      match the documentation with reality instead of fixing makefiles.
      Signed-off-by: default avatarMasahiro Yamada <yamada.masahiro@socionext.com>
      Signed-off-by: default avatarLinus Torvalds <torvalds@linux-foundation.org>
      37d69ee3
  6. 05 May, 2017 1 commit
  7. 03 May, 2017 3 commits
  8. 01 May, 2017 2 commits
  9. 28 Apr, 2017 2 commits