Commit 2b5a69d8 authored by Edward Hervey's avatar Edward Hervey 🤘 Committed by Edward Hervey

bootstrap: Fix dnf/yum usage

yum is the default on fedora >= 23
parent ec5b9220
......@@ -119,7 +119,10 @@ class RedHatBootstrapper (UnixBootstrapper):
def __init__(self, config, offline):
UnixBootstrapper.__init__(self, config, offline)
if self.config.distro_version in [DistroVersion.FEDORA_23, DistroVersion.FEDORA_24, DistroVersion.FEDORA_25]:
if self.config.distro_version in [DistroVersion.FEDORA_23,
DistroVersion.FEDORA_24, DistroVersion.FEDORA_25,
DistroVersion.FEDORA_26, DistroVersion.FEDORA_27,
DistroVersion.FEDORA_28, DistroVersion.FEDORA_29]:
self.tool = 'dnf install %s'
else:
self.tool = 'yum install %s'
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment