Commit bc624821 authored by Nirbheek Chauhan's avatar Nirbheek Chauhan 🐜
Browse files

cerbero: Remove an outdated build-tools error about bootstrap

The instruction given is no longer valid. `-c config/foo bootstrap`
is a superset of `bootstrap` now.

Also, this error gets hit when we run `fetch-bootstrap` for the first
time.
parent 75b669ed
...@@ -89,8 +89,8 @@ class BuildTools (BootstrapperBase, Fetch): ...@@ -89,8 +89,8 @@ class BuildTools (BootstrapperBase, Fetch):
config.build_tools_cache = self.config.build_tools_cache config.build_tools_cache = self.config.build_tools_cache
config.external_recipes = self.config.external_recipes config.external_recipes = self.config.external_recipes
if config.toolchain_prefix and not os.path.exists(config.toolchain_prefix): if not os.path.exists(config.toolchain_prefix):
raise ConfigurationError(_("Please run bootstrap without any '-c' arguments first to setup build-tools for this machine")) os.makedirs(config.toolchain_prefix)
if not os.path.exists(config.prefix): if not os.path.exists(config.prefix):
os.makedirs(config.prefix) os.makedirs(config.prefix)
if not os.path.exists(config.sources): if not os.path.exists(config.sources):
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment