Commit 46d7c201 authored by Sebastian Dröge's avatar Sebastian Dröge
Browse files

It's Jessie, not Jessy

parent 7316bfbd
......@@ -55,7 +55,7 @@ class DebianBootstraper (UnixBootstraper):
DistroVersion.UBUNTU_LUCID: ['libgtk2.0-dev'],
DistroVersion.UBUNTU_NATTY: ['libgtk2.0-dev'],
DistroVersion.DEBIAN_WHEEZY: ['libgdk-pixbuf2.0-dev'],
DistroVersion.DEBIAN_JESSY: ['libgdk-pixbuf2.0-dev'],
DistroVersion.DEBIAN_JESSIE: ['libgdk-pixbuf2.0-dev'],
DistroVersion.UBUNTU_ONEIRIC: ['libgdk-pixbuf2.0-dev'],
DistroVersion.UBUNTU_PRECISE: ['libgdk-pixbuf2.0-dev'],
}
......
......@@ -51,7 +51,7 @@ class DistroVersion:
''' Enumeration of supported distribution versions '''
DEBIAN_SQUEEZE = 'debian_squeeze'
DEBIAN_WHEEZY = 'debian_wheezy'
DEBIAN_JESSY = 'debian_jessy'
DEBIAN_JESSIE = 'debian_jessy'
UBUNTU_MAVERICK = 'ubuntu_maverick'
UBUNTU_LUCID = 'ubuntu_lucid'
UBUNTU_NATTY = 'ubuntu_natty'
......
......@@ -148,8 +148,8 @@ def system_info():
distro_version = DistroVersion.DEBIAN_SQUEEZE
elif d[1].startswith('7.') or d[1].startswith('wheezy'):
distro_version = DistroVersion.DEBIAN_WHEEZY
elif d[1].startswith('jessy'):
distro_version = DistroVersion.DEBIAN_JESSY
elif d[1].startswith('jessie'):
distro_version = DistroVersion.DEBIAN_JESSIE
else:
raise FatalError("Distribution '%s' not supported" % str(d))
elif d[0] in ['RedHat', 'Fedora']:
......
......@@ -45,7 +45,7 @@ class Package(package.Package):
if self.config.target_platform != Platform.LINUX or \
self.config.target_distro_version not in \
[DistroVersion.DEBIAN_WHEEZY,
DistroVersion.DEBIAN_JESSY,
DistroVersion.DEBIAN_JESSIE,
DistroVersion.UBUNTU_NATTY,
DistroVersion.UBUNTU_ONEIRIC,
DistroVersion.UBUNTU_PRECISE,
......
......@@ -45,7 +45,7 @@ class Package(package.Package):
if self.config.target_platform != Platform.LINUX or \
self.config.target_distro_version not in \
[DistroVersion.DEBIAN_WHEEZY,
DistroVersion.DEBIAN_JESSY,
DistroVersion.DEBIAN_JESSIE,
DistroVersion.UBUNTU_NATTY,
DistroVersion.UBUNTU_ONEIRIC,
DistroVersion.UBUNTU_PRECISE,
......
......@@ -104,7 +104,7 @@ class Recipe(recipe.Recipe):
self.config_sh = 'CFLAGS="%s" ./configure' % self._gio_flags('/usr/lib/gio/modules/', '/usr/lib/i386-linux-gnu/gio/modules')
elif self.config.target_arch == Architecture.X86_64:
self.config_sh = 'CFLAGS="%s" ./configure' % self._gio_flags('/usr/lib/gio/modules/', '/usr/lib/x86_64-linux-gnu/gio/modules')
elif self.config.target_distro == Distro.DEBIAN and self.config.target_distro_version in [DistroVersion.DEBIAN_WHEEZY, DistroVersion.DEBIAN_JESSY]:
elif self.config.target_distro == Distro.DEBIAN and self.config.target_distro_version in [DistroVersion.DEBIAN_WHEEZY, DistroVersion.DEBIAN_JESSIE]:
if self.config.target_arch == Architecture.X86:
self.config_sh = 'CFLAGS="%s" ./configure' % self._gio_flags('/usr/lib/i386-linux-gnu/gio/modules')
elif self.config.target_arch == Architecture.X86_64:
......
......@@ -87,7 +87,7 @@ class Recipe(recipe.Recipe):
self.config_sh = 'CFLAGS="%s" ./configure' % self._gtk_flags('/usr/lib/gtk-2.0', '/usr/lib/i386-linux-gnu/gtk-2.0', '/usr/share/themes')
elif self.config.target_arch == Architecture.X86_64:
self.config_sh = 'CFLAGS="%s" ./configure' % self._gtk_flags('/usr/lib/gtk-2.0', '/usr/lib/x86_64-linux-gnu/gtk-2.0', '/usr/share/themes')
elif self.config.target_distro == Distro.DEBIAN and self.config.target_distro_version in [DistroVersion.DEBIAN_WHEEZY, DistroVersion.DEBIAN_JESSY]:
elif self.config.target_distro == Distro.DEBIAN and self.config.target_distro_version in [DistroVersion.DEBIAN_WHEEZY, DistroVersion.DEBIAN_JESSIE]:
if self.config.target_arch == Architecture.X86:
self.config_sh = 'CFLAGS="%s" ./configure' % self._gtk_flags('/usr/lib/i386-linux-gnu/gtk-2.0', None, '/usr/share/themes')
elif self.config.target_arch == Architecture.X86_64:
......
......@@ -19,7 +19,7 @@ class Recipe(recipe.Recipe):
if self.config.target_platform != Platform.LINUX or \
self.config.target_distro_version not in \
[DistroVersion.DEBIAN_WHEEZY,
DistroVersion.DEBIAN_JESSY,
DistroVersion.DEBIAN_JESSIE,
DistroVersion.UBUNTU_NATTY,
DistroVersion.UBUNTU_ONEIRIC,
DistroVersion.UBUNTU_PRECISE,
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment