mbuf: Use SLIRP_DEBUG to enable mbuf debugging instead of DEBUG

DEBUG is set by a number of IDEs and development environments (*cough*
xcode *cough*).  This means we use mbuf duplication when we don't need
(or expect) it.  Change the name to SLIRP_DEBUG to enable this feature.

Signed-off-by: Pablo Fiori <pablofiori@fb.com>
Signed-off-by: Brett Nash <nash@fb.com>     
3 jobs for debug-fix in 3 minutes and 10 seconds (queued for 11 seconds)