Commit 5a49fa9b authored by Jakob Bornecrantz's avatar Jakob Bornecrantz

cmake: Build minimum version

Ubuntu 18.04 is the only debian based distro currently that doesn't have
cmake 3.13 packaged. And Ubuntu 18.04 is not supported for other reasons.

Closes #50
parent f9743018
Pipeline #108094 passed with stages
in 2 minutes and 8 seconds
# Copyright 2018-2020, Collabora, Ltd.
# SPDX-License-Identifier: BSL-1.0
cmake_minimum_required(VERSION 3.10.0)
cmake_minimum_required(VERSION 3.13.0)
project(XRT VERSION 0.1.0)
# CMake 3.11 introduced CMP0072 - Prefer GLVND
......
......@@ -29,7 +29,7 @@ and aims to support other operating systems in the near future.
Dependencies include:
* [CMake][] 3.10 or newer
* [CMake][] 3.13 or newer (Note Ubuntu 18.04 only has 3.10)
* Vulkan headers
* OpenGL headers
* Eigen3
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment