Commit 205c566e authored by Martin Koch's avatar Martin Koch
Browse files

Add version requirement >= 2.60 for the GLib family of libraries

    - due to usage of Reference-counted-data in lib/wptoml/array.cpp
      (requires >= 2.58, see https://developer.gnome.org/glib/stable/glib-Reference-counted-data.html)
    - and usage of G_GNUC_FALLTHROUGH in lib/wp/object-interest.c
      (requires 2.60, see https://developer.gnome.org/glib/stable/glib-Miscellaneous-Macros.html#G-GNUC-FALLTHROUGH:CAPS

)
Signed-off-by: Martin Koch's avatarMartin Koch, ESE GmbH <martin.koch@ese.de>
parent 9f397068
Pipeline #160625 passed with stages
in 1 minute and 22 seconds
......@@ -30,10 +30,10 @@ cmake = import('cmake')
cpptoml = cmake.subproject('cpptoml')
cpptoml_dep = cpptoml.dependency('cpptoml')
gobject_dep = dependency('gobject-2.0')
gmodule_dep = dependency('gmodule-2.0')
gio_dep = dependency('gio-2.0')
giounix_dep = dependency('gio-unix-2.0')
gobject_dep = dependency('gobject-2.0', version : '>= 2.60')
gmodule_dep = dependency('gmodule-2.0', version : '== ' + gobject_dep.version())
gio_dep = dependency('gio-2.0', version : '== ' + gobject_dep.version())
giounix_dep = dependency('gio-unix-2.0', version : '== ' + gobject_dep.version())
pipewire_dep = dependency('libpipewire-0.3')
gnome = import('gnome')
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment