Commit b22181d9 authored by Eric Engestrom's avatar Eric Engestrom Committed by Eric Engestrom

README: update Mesa build instructions

The platforms option is called `--with-platforms` in autotools, but
since it's on the way out let's directly update to the meson option
name.
Also, remove specific (and ancient!) version and fix 'comma' typo.
Signed-off-by: Eric Engestrom's avatarEric Engestrom <eric@engestrom.ch>
Reviewed-by: Dylan Baker's avatarDylan Baker <dylan@pnwbakers.com>
Reviewed-by: Jordan Justen's avatarJordan Justen <jordan.l.justen@intel.com>
parent a4ac0ded
......@@ -73,8 +73,8 @@ If you choose to enable support for a given platform (for example,
not installed. Listed below are the required packages for each platform.
If you install Mesa from source, then Mesa must be configured with option
`--with-egl-platforms=PLATFORM_LIST`, where PLATFORM_LIST is
a comman-separated list of any combination of "x11", "wayland", and "drm".
`-D platforms=PLATFORM_LIST`, where PLATFORM_LIST is
a comma-separated list of any combination of "x11", "wayland", and "drm".
- GLX:
- Archlinux: pacman -S libgl libxcb libx11
......@@ -82,18 +82,18 @@ a comman-separated list of any combination of "x11", "wayland", and "drm".
- Debian: apt-get install libgl1-mesa-dev libxcb1-dev libx11-dev
- X11/EGL:
- all: If you choose to install Mesa from source, use --with-egl-platforms=x11.
- all: If you choose to install Mesa from source, use -D platforms=x11
- Archlinux: pacman -S libegl libxcb libx11
- Fedora 17: yum install mesa-libEGL-devel libxcb-devel libX11-devel
- Debian: apt-get install libegl1-mesa-dev libxcb1-dev libx11-dev
- Wayland:
- all: Install wayland>=1.0 from source.
- all: Install mesa-9.1-devel from source. Use --with-egl-platforms=wayland.
- all: Install Mesa from source. Use -D platforms=wayland
- Debian: apt-get install libwayland-dev
- GBM:
- all: Install mesa-9.1-devel from source. Use --with-egl-platforms=drm.
- all: Install Mesa from source. Use -D platforms=drm
- Archlinux: pacman -S systemd
- Fedora 17: yum install libudev-devel
- Debian: apt-get install libgbm-dev libudev-dev
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment