Commit c878a27d authored by Kenny Ho's avatar Kenny Ho Committed by Marek Olšák

cmake: make gbm a required build dependency

To support the gbm platform on a default build
Signed-off-by: Kenny Ho's avatarKenny Ho <Kenny.Ho@amd.com>
Signed-off-by: 's avatarMarek Olšák <marek.olsak@amd.com>
parent 7303584f
......@@ -141,7 +141,7 @@ IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
add_definitions(-DPIGLIT_HAS_GLX)
endif()
pkg_check_modules(GBM QUIET gbm>=17.1)
pkg_check_modules(GBM REQUIRED gbm>=17.1)
if(GBM_FOUND)
set(PIGLIT_HAS_GBM True)
add_definitions(-DPIGLIT_HAS_GBM)
......
......@@ -33,7 +33,7 @@ First of all, you need to make sure that the following are installed:
- numpy (http://www.numpy.org)
- six (https://pypi.python.org/pypi/six)
- cmake (http://www.cmake.org)
- GL, glu and glut libraries and development packages (i.e. headers)
- GL, gbm, glu and glut libraries and development packages (i.e. headers)
- X11 libraries and development packages (i.e. headers)
- waffle (http://www.waffle-gl.org)
- mako
......@@ -97,7 +97,7 @@ flags), then you must invoke cmake with options
Install development packages.
$ sudo apt-get install cmake g++ mesa-common-dev libgl1-mesa-dev python-numpy python-mako freeglut3-dev x11proto-gl-dev libxrender-dev libwaffle-dev
$ sudo apt-get install cmake g++ mesa-common-dev libgl1-mesa-dev python-numpy python-mako freeglut3-dev x11proto-gl-dev libxrender-dev libwaffle-dev libgbm-dev
Configure and build.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment