Commit 825c4fe5 authored by Dylan Baker's avatar Dylan Baker

generated_tests: Fix require_extensions for constant_array_size

The extension requires a GL_ prefix, which the template didn't have.
Signed-off-by: default avatarDylan Baker <dylanx.c.baker@intel.com>
Tested-by: Jason Ekstrand's avatarJason Ekstrand <jason@jlekstrand.net>
parent e8fbd270
...@@ -191,8 +191,8 @@ class ParserTest(object): ...@@ -191,8 +191,8 @@ class ParserTest(object):
float(self.glsl_version()) / 100) float(self.glsl_version()) / 100)
req_extensions = list(self.additional_extensions()) req_extensions = list(self.additional_extensions())
if req_extensions: if req_extensions:
parser_test += ' * require_extensions: {0}\n'.format( parser_test += ' * require_extensions: {}\n'.format(
' '.join(req_extensions)) ' '.join('GL_{}'.format(r) for r in req_extensions))
parser_test += ' * [end config]\n' parser_test += ' * [end config]\n'
parser_test += ' *\n' parser_test += ' *\n'
parser_test += ' * Check that the following test vectors are constant'\ parser_test += ' * Check that the following test vectors are constant'\
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment