Commit 7c0960df authored by Dylan Baker's avatar Dylan Baker

tox.ini: Set the mako version to the minimum version in cmake

We actually define a minimum required mako version in cmake. Since tox
is supposed to be useful for testing, we should test that version.

Mako 1.0.2 contains bug fixes for python 3.5. For versions of python
earlier than 3.5 0.8.0, is still sufficient, but for 3.5 1.0.2 is needed.

CMake is updated to check this as well.
Signed-off-by: default avatarDylan Baker <dylanx.c.baker@intel.com>
parent c7fe9388
......@@ -204,9 +204,17 @@ ENDIF()
set(Python_ADDITIONAL_VERSIONS
3.5 3.4 3.3 2.7)
find_package(PythonInterp REQUIRED)
find_package(PythonNumpy 1.6.2 REQUIRED)
find_package(PythonMako 0.8.0 REQUIRED)
find_package(PythonSix 1.5.2 REQUIRED)
find_package(PythonNumpy 1.6.2 REQUIRED)
# CMake doesn't have a VERSION_GREATER_EQUAL function, at least as of 3.0,
# And mako 1.0.2 contains bug fixes required for python 3.5 to work, so
# the only solution (short of having a series of "OR" statements, is this)
if (PYTHON_VERSION_STRING VERSION_GREATER 3.4.999999)
find_package(PythonMako 1.0.2 REQUIRED)
else ()
find_package(PythonMako 0.8.0 REQUIRED)
endif (PYTHON_VERSION_STRING VERSION_GREATER 3.4.999999)
# Default to compiling with debug information (`gcc -g`):
if(NOT CMAKE_BUILD_TYPE)
......
......@@ -6,7 +6,6 @@ skipsdist=True
[testenv]
passenv=HOME
deps =
mako
nose
coverage
six==1.5.2
......@@ -16,6 +15,8 @@ deps =
py27-{accel,noaccel}: mock==1.0.1
py27-accel: backports.lzma
py27-accel: subprocess32
py{27,33,34}: mako==0.8.0
py35: mako==1.0.2
generator: numpy
commands =
{accel,noaccel}: nosetests unittests []
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment