Commit 6f075eea authored by Dylan Baker's avatar Dylan Baker

CMake: Fix GBM version requirement for DMA BUF tests

In commit a1efbfb9 support was added for dmabuf with GBM on non-intel
platforms, but the requirements were set incorrectly. They require
symbols added in mesa commit 8aeb6d76, which is not in any mesa 11
release, only in mesa 12.

This corrects the requirement to be version 12.0

bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=97435Signed-off-by: default avatarDylan Baker <dylanx.c.baker@intel.com>
Reviewed-by: Eric Anholt's avatarEric Anholt <eric@anholt.net>
parent a6c359be
......@@ -141,7 +141,7 @@ IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
if(GBM_FOUND)
set(PIGLIT_HAS_GBM True)
add_definitions(-DPIGLIT_HAS_GBM)
if (GBM_VERSION VERSION_GREATER "11.1")
if (GBM_VERSION VERSION_EQUAL "12.0" OR GBM_VERSION VERSION_GREATER "12.0")
set(PIGLIT_HAS_GBM_BO_MAP True)
add_definitions(-DPIGLIT_HAS_GBM_BO_MAP)
endif()
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment