Commit 2a4fd5a8 authored by Dylan Baker's avatar Dylan Baker

CMake: Enable python 3.x for building

The generators have supported 3.x for some time, this now makes 3.x the
default, and falls back to 2.7

This has been tested with 3.5 and 2.7
Signed-off-by: default avatarDylan Baker <dylanx.c.baker@intel.com>
Acked-by: Jose Fonseca's avatarJose Fonseca <jfonseca@vmware.com>
parent 6098c203
......@@ -201,7 +201,9 @@ IF(PIGLIT_BUILD_GLX_TESTS)
pkg_check_modules(GLPROTO REQUIRED glproto)
ENDIF()
find_package(PythonInterp 2.7 REQUIRED)
set(Python_ADDITIONAL_VERSIONS
3.5 3.4 3.3 2.7)
find_package(PythonInterp REQUIRED)
find_package(PythonNumpy 1.6.2 REQUIRED)
find_package(PythonMako 0.8.0 REQUIRED)
find_package(PythonSix 1.4.0 REQUIRED)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment