Commit 29cf1d73 authored by Dylan Baker's avatar Dylan Baker

dependencies: Bump numpy version to 1.7.0 in cmake and tox

The previous version (1.6.2) fails to compile against python 3, and is
from 2012. Version 1.7.0 does compile against python 3, and is still
from February 2013, old enough that even stable Linux distributions
should have picked it up by now.
Signed-off-by: default avatarDylan Baker <dylanx.c.baker@intel.com>
parent 7c0960df
......@@ -205,7 +205,7 @@ set(Python_ADDITIONAL_VERSIONS
3.5 3.4 3.3 2.7)
find_package(PythonInterp REQUIRED)
find_package(PythonSix 1.5.2 REQUIRED)
find_package(PythonNumpy 1.6.2 REQUIRED)
find_package(PythonNumpy 1.7.0 REQUIRED)
# CMake doesn't have a VERSION_GREATER_EQUAL function, at least as of 3.0,
# And mako 1.0.2 contains bug fixes required for python 3.5 to work, so
......
......@@ -17,7 +17,7 @@ deps =
py27-accel: subprocess32
py{27,33,34}: mako==0.8.0
py35: mako==1.0.2
generator: numpy
generator: numpy==1.7.0
commands =
{accel,noaccel}: nosetests unittests []
generator: nosetests generated_tests/test_generators.py []
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment