Commit 05c319df authored by Timothy Arceri's avatar Timothy Arceri

built-in-constants: fix desktop GL version check for geometry shaders

The check is meant to compare GLSL version which for OpenGL 3.2 is
1.50.
Reviewed-by: default avatarMarek Olšák <marek.olsak@amd.com>
parent b8ecae3e
......@@ -400,7 +400,7 @@ create_shader(GLenum type)
* OpenGL 3.2.
*/
if (type == GL_GEOMETRY_SHADER &&
required_glsl_version < 320)
required_glsl_version < 150)
return 0;
}
/* Only create compute shaders when explicitly requested
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment