Commit dc160055 authored by Vinson Lee's avatar Vinson Lee Committed by Vinson Lee
Browse files

map_buffer_range_error_check: Require OpenGL 1.5.



glGenBuffers is available only if the GL version is 1.5 or greater.
Signed-off-by: default avatarVinson Lee <vlee@vmware.com>
Reviewed-by: Brian Paul's avatarBrian Paul <brianp@vmware.com>
parent 8dd3cda8
...@@ -45,6 +45,11 @@ piglit_init(int argc, char *argv[]) ...@@ -45,6 +45,11 @@ piglit_init(int argc, char *argv[])
GLbitfield access = GL_MAP_READ_BIT | GL_MAP_WRITE_BIT; GLbitfield access = GL_MAP_READ_BIT | GL_MAP_WRITE_BIT;
GLuint buffer; GLuint buffer;
if (!GLEW_VERSION_1_5) {
printf("Requires OpenGL 1.5\n");
piglit_report_result(PIGLIT_SKIP);
}
piglit_require_extension("GL_ARB_map_buffer_range"); piglit_require_extension("GL_ARB_map_buffer_range");
glGenBuffers(1, &buffer); glGenBuffers(1, &buffer);
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment